Microsoft Office Outage

Incident Report for Sentinel Data Solutions

Resolved

The problems with Microsoft Office have been resolved. If your experiencing any further issues, please call 01425 527014
Posted Jan 17, 2025 - 11:51 GMT

Update

We are continuing to investigate this issue.
Posted Jan 17, 2025 - 11:43 GMT

Update

Microsoft have provided a resolution. We're working on deploying the fix.. We'll be in contact shortly..
Posted Jan 17, 2025 - 09:45 GMT

Investigating

Good morning, we are aware of an issue with Microsoft Office. We're currently working with Microsoft to find a resolution. Further updates to follow.
Posted Jan 17, 2025 - 08:22 GMT
This incident affected: Contacting us/ Tools/ Portals (Telephone System, E-mail).