Powercut

Incident Report for Sentinel Data Solutions

Resolved

Power has been restored to our office. Operation will resume as normal.
Posted Jan 22, 2026 - 15:44 GMT

Identified

A fault has been identified with electrical works that have taken Salisbury road that has caused a power cut at our office. This has reduced the service we can provide. We apologies for any delays that occur because of this. We are still operational but with reduced service.
Posted Jan 22, 2026 - 15:10 GMT