Device Login issues

Incident Report for Sentinel Data Solutions

Resolved

We understand that the AWS outage has now been resolved. We can see all service are up and running, we are however aware of some services running slowly as they clear the backlog. For further information please follow the BBC news feed https://www.bbc.co.uk/news/live/c5y8k7k6v1rt
Posted Oct 20, 2025 - 14:46 BST

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 11:21 BST

Monitoring

Good Morning,

A Global outage which has caused issues with Amazon Web Services (AWS) and its customers, our suppliers, is believed to be resolved, services such as web hosting, DNS, Anti-Virus, connectivity...

The outage has caused problems with logging into Windows Devices as well as delays in Windows update services.

We believe that the issue has now been resolved, if your still experiencing a problem please restart your machine and then login again, failing that please contact us.

Kind regards,

Sentinel Support
Posted Oct 20, 2025 - 11:12 BST
This incident affected: Contacting us/ Tools/ Portals (Telephone System, E-mail, Sentinel Data Solutions Website, Direct Debit Payments), Core Network Services (Sentinel Cloud, Sentinel Voice), and Cloudflare Manchester, United Kingdom - (MAN).