The telephony issue has now been resolved. We'll continue to monitor the service with our upstream provider over the next 24 hours.
Sorry for the inconvenience that this may have caused.
Posted Mar 11, 2025 - 12:06 GMT
Monitoring
Traffic has been returning to normal levels in most areas of our network. We'll continue to monitor and provide further updates within one hour.
Posted Mar 11, 2025 - 11:29 GMT
Investigating
We're aware of an issue with our upstream provider whereby a caller will continue to hear the telephone ring even when the call has been answered. The recipient of the call can only hear silience.
We've raised this with our upstream provider who are investigation. Further updates to follow..
Posted Mar 11, 2025 - 10:19 GMT
This incident affected: Contacting us/ Tools/ Portals (Telephone System).