Microsoft 365 Delivery Issues

Incident Report for Sentinel Data Solutions

Resolved

This incident has been resolved.
Posted Jul 18, 2023 - 14:56 BST

Update

Microsoft identified that the fix had an unintended impact and resulted in mail flow issues, generating NDRs for some users. They have reverted the fix that caused impact to mail flow and are now deploying a revised fix to effectively discard the excessive CFMs that are causing email delivery delays.

Users may have received Undeliverable messages whilst this temporary fix was put in place.
Posted Jul 18, 2023 - 12:52 BST

Identified

Issue Description : Users’ inbound and outbound email delivery may be delayed for 15 minutes or longer in Exchange Online.

More info : The issue isn’t client-specific, thus this impact may occur in all Exchange Online connection methods.

Current Update : 18/07/2023 08:37:00 AM – Microsoft implemented an additional fix to prevent the Control Flow Messages (CFMs) that are impacting email delivery. They are continuing to monitor the environment to ensure that the delays do not reoccur. It is possible that during this time, users may see stale free/busy information.

Scope of impact : This issue may affect any user sending or receiving mail in Exchange Online.

Root cause : A recent code change related to our free/busy publishing APIs has resulted in an influx of Control Flow Messages (CFMs), which are sent during certain free/busy operations such as calendar replication, to be sent for other instances where CFMs are not necessary. This is resulting in a spike in messages on Exchange Online infrastructure, which is resulting in message queuing.
Posted Jul 18, 2023 - 11:21 BST
This incident affected: Contacting us/ Tools/ Portals (E-mail).